Previous Lecture Complete and continue  

  Cisco Simulator

Can you complete the simulation?


You may not have used Cisco devices in the past, but try to complete this simulation.

>>> Type "help" or "show me" for tips. <<<

Otherwise use ? and tab as you would normally on a Cisco device.

Demo: Click here to see a video showing me completing the simulation:

34 comments
denis tupou
Hello, this is Denis......I was wondering if you can help me out as Im trying to figure out ACL and how it works......only if you are of course......Its actuallly a CCNA 2 case study......I have already implemented OSPF, NAT and DHCP....all that is left is ACL......
David Bombal
Hi Denis,

This course contains videos and sims about ACLs. It also contains information about OSPF, NAT and DHCP.

ACLs:
http://academy.gns3.com/courses/the-complete-networking-fundamentals-course-your-ccna-start/lectures/991490

All the best!
David
Mohammed Yaqoob
amazing
David Bombal
Thank you Mohammed!
undefined undefined
Wow,, didn't know i forgot such basic commands even after obtaining CCNP.
David Bombal
It is amazing how much one forgets :)
Junior Santiago
is there a way to reset the simulation if a mistake has taken place ?
I accidentally fat fingered the IP address in the switch, see output below
•S1# conf t
% Invalid input detected type 'help' or 'show me'
S1# exit
Router1(config)#
!
after issuing ►exit i got logged out of the switch and into the router and kept getting ▬ % Invalid input detected type 'help' or 'show me' ▬ at every single command there after, This is very unique and useful to have web-based simulations like this, an amazing price too, keep it up, thank you
David Bombal
Hi Junior,

The simulation is restarted every time you refresh your browser. So, use control+F5 for example on Windows to refresh the page and the simulation will restart.

Thank you for the feedback!

All the best!
David
Arentas NET
Simulator does not behave like it suppose to. even if not in privilege mode you can type commands that simulator awaiting.. and if you use "help" then its just to easy. no?
David Bombal
Hi Arentas,

Thank you for the feedback. I have just tested the simulator and I am not able to type configuration commands for example in user mode.

Can you be specific about which commands you are able to type in the wrong modes so we can investigate and fix as needed.

The "show me" command shows all the steps. The "help" command just shows the next command expected. These are to help especially people new to Cisco.

Regards,
David
Gary Robinson
The commands worked for me. I'm using Opera version 42.0.2393.94. David what are you using to do these simulations? They are cool and browser based at that.
David Bombal
Hi Gary,

Thank you for the feedback.

We have written the software and simulations. We are currently developing more complex versions with multiple devices and instructions as part of the sim. Any suggestions on ways we can improve the sims are welcome.

Regards,
David
Greg Banach
I have tried typing parts of the commands and pressing Tab. No commands worked for me.
David Bombal
Hi Greg,

I have just tested this on Safari, Chrome and FireFox and they are working for me (Mac OS). Others have also confirmed that the sims are working as expected.

Can you give me details of the OS and browser you are using?

Regards,
David
James Scharoun
working fine so far!
Win 7 with chrome i5 with 8 gig
David Bombal
Thanks for all the input and feedback James!
shane meister
Simulation is very limited, some standard cisco commands don't seem to work eg. ? for available commands.
Abbreviated commands worked well. I'm hoping the actual simulators actually simulate a switch rather than just guide you thru the commands in a CLI look a like environment
David Bombal
Hi Shane,

The simulations don't try to fully replicate the Cisco IOS. We already have options like GNS3 for that. These sims are more like what you may find in your exam. They test your knowledge on a specific topic and help reinforce knowledge.

Hopefully the sims also help you learn better - rather than just passively watching videos, you are engaged in the learning in the course and forced to think through scenarios that require your active involvement.

However, the simulations should support options like ? and tab and abbreviated commands for the commands needed to complete the simulations. Please let me know which commands you tried where the ? did not work. TIP: I suggest you type part of a command and then press tab to see the full command and then use ? to see any options related to the command.

Please do let me know if you find a bug so that we can keep improving the course for everyone's benefit.

All the best!
David
Constantin Stan
Works fine in Chrome ( Win8.1)and i disabled all ad-blockers.
Works fine in Firefox(Win8.1). Worst case, install latest Adobe Flash.
Works in Firefox( GhostBSD ) :)
David Bombal
Hi Constantin,

Thanks for the feedback.

These sims are using HTML5, so no flash is required :)

Regards,
David
frank obie
I'm having hard time trying to bring up the switch screen for the simulator its not displaying.i'm using windows 7 on google chrome.
any suggestion will help.
Thanks
Sean Wilkerson
It took about 20 seconds to load for me.
David Bombal
Hi Frank.

I just checked and it is working for me.

Could you try with the following:
1) Do not use private / stealth mode.
2) And then turn off anti virus software (the sims are hosted on a different server, so your software may be blocking connections)

Regards,
David
sandrino brakenhoff
strange when you switch back by EXIT or Control Z you go in to a natter equipment?
Tyler Waterman
Great course! Very helpful!

One question, the sims do not display for me. All i have is a blank window where the sim should be according to your demo. Any idea how I could fix this? I have no ad blocker or anti virus plugins in my browser if that helps. Thanks!
David Bombal
Thanks Tyler.

I just tried FireFox on Windows 7 and it works for me..... hmm..... please do let me know if you figure what what caused the issue for you.
David Bombal
Hi Tyler,

This has happened previously on a Mac when using Safari with private browsing.

Please try another browser such as Chrome. I also found rebooting my Mac solved the problem.

If you are not using a Mac, can you give me details of the system you are using and the browser?

Regards,
David
Tyler Waterman
I am using firefox on windows 7. I disabled private browsing with no luck but it does work on Internet Explorer so I can use that. If I ever figure out why it doesn't work on firefox, I will be sure to let you know. Thanks for the help!
Sebastian
Good lab :) thx
David Bombal
Thank you Sebastian!
undefined undefined
This lab is broken, any configuration command is seen as 'invalid input' after a 'show me' command is run
David Bombal
Hi,

I have just tested the lab and it is working for me.

I am not sure if I understand your comment, but the show me command lists the commands the simulation.

Here is a video showing me completing the simulation:
http://screencast.com/t/Wxb1Rr1KBhfH

Regards,
David
Michael Casey
Thanks for a good lab
David Bombal
Hi Michael,

Thank you for the feedback!

I am glad you found the simulation useful. We adding many more :)

Regards,
David